OkHttp

Additional

Language
Java
Version
parent-3.5.0 (Dec 1, 2016)
Created
Jul 23, 2012
Updated
Jan 19, 2019
Owner
Square (square)
Contributors
Adam Stroud (adstro)
yelinaung
Artem Zinnatullin :slowpoke: (artem-zinnatullin)
anderius
romkavt
narayank
Felipe Lima (felipecsl)
Tolriq
lexer
adriancole
Egorand
edenman
aried3r
rjrjr
mlc
desseim
mruddy
the4thfloor
Show all (170)170
Activity
Badge
Generate
Download
Source code

Promotion

OkHttp

An HTTP & HTTP/2 client for Android and Java applications. For more information see the website and the wiki.

Requirements

OkHttp works on Android 5.0+ (API level 21+) and on Java 8+.

OkHttp has one library dependency on Okio, a small library for high-performance I/O. It works with either Okio 1.x (implemented in Java) or Okio 2.x (upgraded to Kotlin).

We highly recommend you keep OkHttp up-to-date. As with auto-updating web browsers, staying current with HTTPS clients is an important defense against potential security problems. We track the dynamic TLS ecosystem and adjust OkHttp to improve connectivity and security.

OkHttp uses your platform's built-in TLS implementation. On Java platforms OkHttp also supports Conscrypt, which integrates BoringSSL with Java. OkHttp will use Conscrypt if it is the first security provider:

Security.insertProviderAt(Conscrypt.newProvider(), 1);

The OkHttp 3.12.x branch supports Android 2.3+ (API level 9+) and Java 7+. These platforms lack support for TLS 1.2 and should not be used. But because upgrading is difficult we will backport critical fixes to the 3.12.x branch through December 31, 2020.

Download

Download the latest JAR or configure this dependency:

implementation("com.squareup.okhttp3:okhttp:3.12.1")

Snapshots of the development version are available in Sonatype's snapshots repository.

MockWebServer

A library for testing HTTP, HTTPS, and HTTP/2 clients.

MockWebServer coupling with OkHttp is essential for proper testing of HTTP/2 so that code can be shared.

Download

Download the latest JAR or configure this dependency:

testImplementation("com.squareup.okhttp3:mockwebserver:3.12.1")

R8 / ProGuard

If you are using R8 or ProGuard add the options from okhttp3.pro.

You might also need rules for Okio which is a dependency of this library.

License

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.